This project is read-only.

Several issues in latest release

Aug 30, 2011 at 4:27 AM
Edited Sep 2, 2011 at 2:14 AM

There are several issues which, if resolved, would make this a very useful solution.

  • Web Part: The URL to download latest Flash player when it's not installed links to the video file, not the Adobe download page.
    • The Flash message comes from flowplayer.js but it is obscured by the href generated for the video by FLVURL.
  • List View: the Play Video link breaks when clicked from a List View Web Part in a subsite.
    • This is caused by the relative path to the layouts directory in  fldtypes_FLVPlayerField.xml.
  • Pop-up window: it would be great if the window size could be generated from metadata.
    • Add Height/Width columns to the library and read these properties into the JavaScript.
  • The URL to the default flowplayer video file is no longer valid.
  • The Web Part chrome is hard coded to show no title and cannot be overridden by modifying the web part through the UI.
  • VideoPlayer.aspx expects a Title but as no content type is present on the list, users are not prompted to supply this value.

[Edit]

Despite my poor coding skills and hatred of XML I have managed to resolve many of the above issues. However, I'm unable to share them without an appropriate email address. Let me know if you're interested and I will happily provide them.

  • I have include the demo video in the project and deployed it with the script files to reduce reliance on external media and resolve the broken link.
  • I have removed the chrome rendering from CreateChildControls to allow users to modify this setting.
  • Resolved susbite issue with List Views by wading through far too much XML and providing the current site path to the popup window (and stripping out any instance of /Pages, /Lists etc.
  • I have created a "Video" content type including Name, Height and Width columns. Pop-up window size is now determined by the provided values. Defaults are present.
Nov 7, 2013 at 1:44 PM
I am interested in your revised version. My email address is kathyf@cftoday.org. Thank you!

I am seeing another issue with this. If you create folders in your video library (to separate videos by event), the play button displays next to the folder when it should only be showing next to each video file. Just curious if you came across this as well.
Nov 11, 2013 at 8:09 AM
Hi Kathy,

My apologies, I no longer have access to the source code.

The majority of the work is performed in the customised DispForm.aspx. No consideration was given to folder content types.

Consider adding a new "category" column for this purpose.

Regards,

Paul